Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
9
Erster Beitrag:
vor 1 Jahr, 1 Monat
Letzter Beitrag:
vor 1 Jahr
Beteiligte Autoren:
Yogi Yang, Ruben Sanchez Peña, DarrenF

[WM] - Getting Error while uploading APK to Google Store

Startbeitrag von Yogi Yang am 18.07.2016 11:59

Hello,

I have started getting wired error when we try to upload updates to a production APK.

The error is:
Upload failed

Your APK's version code needs to be higher than 77.

Any ideas as to what must be the problem here and how to solve it?

TIA

Yogi Yang

Antworten:

Hi Yogi,

I've never experienced this error before, but it (or something very similar) is discussed on StackOverflow here:

http://stackoverflow.com/questions/15593328/how-to-solve-your-apks-version-code-needs-to-be-higher-than-2-in-google-play

Let us know if this solves your problem?

von DarrenF - am 18.07.2016 13:34
Hello Darren,

I have seen this post. But I am not able to find and/or modify the manifest file.

Once the project is compiled successfully I think WM is removing the file.

How can I get WM to upgrade the code version?

TIA

Yogi Yang

von Yogi Yang - am 18.07.2016 13:44
Hi. What is the version you have in the generation process? "Version Number of the application" screen. This version is the WM put in manifest APK.

Rubén

von Ruben Sanchez Peña - am 18.07.2016 15:33
Hello Ruben,

I am using WM17. My APK version is 1.7.7.0 which is set to auto increment on each compile. The code version as reported by Google Play Store is 74.

TIA

Yogi Yang

von Yogi Yang - am 19.07.2016 03:44
Hi. You can edit the manifest in WM. You can assign the AndroidVersion Code value.

Rubén

von Ruben Sanchez Peña - am 19.07.2016 10:00
Quote
Ruben Sanchez Peña
Hi. You can edit the manifest in WM. You can assign the AndroidVersion Code value.

Rubén

How? From where?

TIA

Yogi Yang

von Yogi Yang - am 19.07.2016 14:44
Hi.

In generation process you have a step where you define the SDK version and a button "Advanced Configuration". There you have a button "Edit Manifest". There you can change the default manifest settings.

Rubén

von Ruben Sanchez Peña - am 19.07.2016 17:08
Ruben,

Thanks.

Finally I have managed to solve this problem. :hot:

Regards,

Yogi Yang

von Yogi Yang - am 22.07.2016 04:48
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.