Query Memory [WD21]

Startbeitrag von iso am 20.07.2016 09:32


I have a procedure that runs through a list of about 300 rows of a table.
Each row executes a number of queries some multiple times with altered parameters.
The results of the queries are added to summary datafile

The problem is the first 20 rows take about 30 seconds then gradually it slows down to crawl by row 100 each row takes about 30 seconds each and then sown to virtually stopped!! If i stop the program the restart the procedure (it picks up where it was stopped) it flies and adds them really fast again.

Any ideas? I ve tried HFreeQuery.

Thanks ISO


Hi Iso,

I have the same kind of problems when executing a few queries many times. I have send a request to PCSoft with an example project, but they could not reproduce the problem (I included a description for reproducing the problem, but in their answer they didn't follow the description, so the problem was not clear). I have no solution, yet.

von Stefan Bentvelsen - am 20.07.2016 10:16
Hi Stefan

I just read through your problem, yes sounds like its the same. if i remove the queries that are repeated it flies through,i don't think the HFreeQuery works!

i am now going to recreate each query thats repeated, thats how desperate ive become :)

von iso - am 20.07.2016 10:51
Hi iso,

do you encounter this problem in test or in runtime?
If in test, check the dynamic audit settings.
If this is enabled, disable it and test it again.

regards, Xavier

von Xavier Schauwvlieghe - am 20.07.2016 10:56
Hello Xavier,

Its in Test Mode, where do i find the Dynamic Audit Settings, cant seem to find it?


von iso - am 20.07.2016 11:11
Hi Xavier,

It probably is that, i ve installed and it works fine!

Many Thanks


von iso - am 20.07.2016 11:21
Hi Iso,

you find the Dynamic Audit on the dashboard if you have added the pane. Right click on the dashboard, check 'Modification mode' on, then right click and add or delete options and check 'modification mode' back off. When you've added the Dynamic Audit pane, click on the arrow - right upper corner and there you can enable or disable it.

cheers, Xavier

von Xavier Schauwvlieghe - am 20.07.2016 11:39
Got it, and it worked, many thanks :)

von iso - am 20.07.2016 12:15
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.