Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
4
Erster Beitrag:
vor 1 Jahr, 4 Monaten
Letzter Beitrag:
vor 1 Jahr, 4 Monaten
Beteiligte Autoren:
Michael Drechsel, Fabrice Harari

[WD20] Thumbnails in a Looper

Startbeitrag von Michael Drechsel am 05.08.2016 08:41

Hi,

I know we have this topic several times ....

I have a Looper with an imagecontrol 80x80 and have defined a thumbnail in the analysis with 80x80 and 160x160.
The source of the looper is a query.

If I understand the help correctly WD should select a thumbnail for the imagecontrol but I have my doubt ....
It´s terrible slow. How can I force the use of a thumbnail ???

Antworten:

Ok, I replaced the query with:

for all pictures where guid=myguid
looperadd(picture.picture...thumbnail)
end


...and voila, its fast.

That means the automatic doesn´t work !!!!

von Michael Drechsel - am 05.08.2016 09:12
Hi Michael

I haven't tested, but my understanding is that the automatic should work when the looper is linked directly to the -FILE-

When you do a query, you are putting an added layer in the middle, and I don't think that queries in any language on any DB know how to manage thumbnails.

IN any case, I find it a good idea to first fill a looper with anything BUT images, then do a secondary loop (sometime on a timer) to fill the images... That is especially useful on slower environment (web, mobile, etc)

Best regards

von Fabrice Harari - am 05.08.2016 14:08
Hi Fabrice,

yes, that also my way.

I think I misunderstud the helpfile in this case ....

von Michael Drechsel - am 05.08.2016 14:11
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.