Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
2
Erster Beitrag:
vor 1 Jahr
Letzter Beitrag:
vor 1 Jahr
Beteiligte Autoren:
Mark Crichton

Run External Report Element was not found

Startbeitrag von Mark Crichton am 10.08.2016 14:55

Hi All

I have reporting problem I though was working, but seems not to be.
Getting error The '' element was not found

Is it possible to run a report that does not exist by name in the application? I can modify an existing report and have a customers version.

What I need is to be able to add a number of "External" reports to the application.

Code sets Reports and Queries folder to the path of the report.
I set the variables and run the following code.
Basic version of code run as below

sOK is string = FReportsAndQueries(dirShared,gsPath)
sOK1is string = FReportsAndQueries(dirUser,gsPath)
iPreview(ipvZoom100)
IInitReportQuery,sRpt,SParam1)
IprintReport(sRpt,sParam2)

The query is in the project and compiled to be visible in R&Q

Am I missing the obvious?
Any comments appreciated
thanks Mark

Antworten:

Hi Folks

I created a test project, and it seems to be working.
Please ignore

von Mark Crichton - am 10.08.2016 22:08
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.