Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 12 Monaten
Letzter Beitrag:
vor 11 Monaten, 4 Wochen
Beteiligte Autoren:
ccc2, Ruben Sanchez Peña, Alexandre Leclerc

[wm21 - android] Error "INSTALL_FAILED_UID_CHANGED"

Startbeitrag von ccc2 am 22.08.2016 12:45

Hi,

this few days I keep getting error "INSTALL_FAILED_UID_CHANGED" when deploy .

i try delete the /data/data/pkg_name , but give error " INSTALL_FAILED_DEXOPT " after that subsequently "INSTALL_FAILED_UID_CHANGED"

I don't think error cause by not enough space or memory since my project is only 7mb.

I tried all suggestion that i found on google . but only change the package name is working .

when I change back to original name and deploy , I get same error.

I tried to do factory reset which only work once after that same error .


why ? is my package name get block ?, do i have to keep change the package name ? any solution?

Antworten:

Hi ccc2,

If you search the web for your error message, you will find people that had the same problem and it looks like manually deleting some files in the data folder, is fixing the problem. It could be due to incorrect software uninstall.

Otherwise, the only UID that comes to my mind is the one in the “key” you must create with compiling the application. This key has a unique signature. If you change that key, I guess that this could lead to some problems.


Best regards,
Alexandre Leclerc

von Alexandre Leclerc - am 22.08.2016 12:58
Hi,

rather than using emulator , I use android table for development testing . because of that install alot of times.

my attempt to solve the problem:

1. When the error first show up, I delete the data folder and problem solve for few days.
after that it's not working

2. I did factory reset . after that working for whole day . after error show up . I try reset twice but no use. the error come out right away

3. since I doing development, I using generic key . I had try create a key but no use.

4. change package name solve the problem. but when I change the name back , error still
popup

5. re download sdk and grandle which solve the problem
android-sdk_r24.4.1-windows
gradle-2.14.1-bin ( gradle 3 milestone 1 or 2 not working).

von ccc2 - am 23.08.2016 01:40
few hours later , problem come out again.

I give up. i will just change package name when the problem come out again

von ccc2 - am 23.08.2016 03:19
Hi. Build Tools versions 24.x don't works for me. I'm in 23.0.1 version without issues.

Version 24.x give me errors deploying the app in my devices. Timeouts and orrupt APKs.

Use the WM option to douwnload the correct Android SDK for WM.

Rubén

von Ruben Sanchez Peña - am 23.08.2016 14:00
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.