Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 10 Monaten, 2 Wochen
Letzter Beitrag:
vor 10 Monaten, 1 Woche
Beteiligte Autoren:
Ola, Danny Lauwers, Yogi Yang

[WD21] F2 does not find all procedures in WD21!

Startbeitrag von Ola am 08.10.2016 08:08

Hi all

I use the F2 function key a lot in the code editor; put the cursor on a procedure name, press F2, and voilà, you jump into that procedure. This is how it worked in WD19, without exception.

But no more! In WD21 F2 finds only some of the procedures, but not all!

I haven't found out, what is the reason that some procedures are not found and some are. Can somebody explain? Maybe I have missed something?

I have 15 sets of procedures, but the dashboard does not tell how many procedures there are in those sets, and I'm too lazy to start counting them. It says I have 8 645 processes. I wonder how you define a process? Surely I can't have too many procedures for WD to handle?

Best regards
Ola

Antworten:

Hi Ola,

I don't know much but I think recompiling the project should solve this problem.

I have faced this problem in WD17 and recompiling the project has always solved this problem for me.

HTH

Yogi Yang

von Yogi Yang - am 12.10.2016 04:15
Hi Yogi,

Since I noticed the problem the app has been recompiled several time. The problem stays.
So far I have pinpointed the problem to one specific procedure. It's an eInvoicing procedure, quite large and calls several other procedures. Maybe it is somehow damaged? It seems to be OK when opened in the code editor and works OK when executed. But it can't be opened with F2 from the edit of another procedure.

Best regards
Ola

von Ola - am 12.10.2016 07:53
Hi,

I noticed that when the level is 2 or more deep F2 cannot find the procedure.

So if you have "Class1.Class2.Procedure" then F2 does not find the Procedure.
When you have "Class3.Procedure2" then F2 does open the Procedure2.

This was not the case in WD19/20 if I remember correctly. I have reported this to PC-Soft.

Maybe your problem is alike ?

Danny

von Danny Lauwers - am 12.10.2016 14:25
Hi Danny,

No. My problem procedure is just a "plain" procedure, one of many in set of procedures.

Ola

von Ola - am 13.10.2016 20:38
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.