Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
13
Erster Beitrag:
vor 1 Jahr, 7 Monaten
Letzter Beitrag:
vor 1 Jahr, 7 Monaten
Beteiligte Autoren:
Bart VDE, GuenterP, DarrenF, Joris, DerekT

WD17: can not generate Executable since Windows10 anniversary update

Startbeitrag von Bart VDE am 15.10.2016 09:20

Hello,

WD17:

Since the Windows 10 anniversary update is installed on my machine, I can not generate an executable of my programs (it's not program related, it never works)
Just the message "WinDev17 has stopped working" whenever I start the generation.

In the log file of Windows I see it is a crash in Windows.UI.Xaml.dll

Anyone else with this kind of problems since this Windows10 update ? And any suggestions for finding a solution ?

Thx.

Antworten:

Hi Bart,

When you say...

Quote
generate an executable


...I presume you mean generating a setup.exe?

This might not help you much at this point, but you got me slightly worried as I too had installed the Win10 anniversary update a couple of days ago and hadn't tried a generation since.

Well, the setup procedure worked for me using WD21; sorry, I don't have WD17 installed in order to try it for you.

I Googled the DLL name and it looks as though the DLL should "help" developers:

Quote
Update to Windows.UI.Xaml.dll to provide improved app developer support


The version referenced is for Win8.1, but it might help you get back to the previous version or find out more?

(https://support.microsoft.com/en-gb/kb/2921128)

Q1: What kind of installer package are you trying to generate? A WD one or a Microsoft one? I ask as it might have a bearing on what the WD setup procedure uses during it's process.

Q2: Is it 32bit or 64bit?

Q3: Are you using the setup wizard or WDInst?

Also found this - https://www.experts-exchange.com/questions/28714425/Application-Error-in-Windows-10.html

von DarrenF - am 15.10.2016 11:33
Hello Darren,

Thanks for your answer.

I tried to generate the 32 bit executable. This is one step of the setup wizard, and it is a that point that WinDev crashes.

The System File Checker I've already tried, without success.
I will also try the DISM thing, who knows...

Q1. WD

Q2. 32 bit

Q3. Using the Setup wizard

Regards,
Bart

von Bart VDE - am 15.10.2016 12:05
I presume you've done all the "standard" stuff, like deleting the .cpl folder etc...?

von DarrenF - am 15.10.2016 12:09
Yes, I did.

Even when I create a complete new project, with nothing more than 1 window and nothing else, the same problem : WinDev crashes when I want to genereate the exe, both in 32 bit and 64 bit.

The DISM stuff didn't help.

I also disabled my virus sanner -> no solution.

I want Windows 7 back :-(

von Bart VDE - am 15.10.2016 12:17
Hi Bart, I just installed WD17 v069t on my 64-bit Windows 10 computer with anniversary update, made a project with a single window, compiled it 32-bit and executed it. No problems whatsoever! Are you using a cracked version or did you use a cracked version at any time before? If yes, bad news: it might be that you have to newly setup your whole computer.

von GuenterP - am 15.10.2016 15:08
Hello Guenter,

It's a WinDev17 version (78p) I have bought from you some time ago, so I hope it isn't cracked ;-)

Regards,
Bart

von Bart VDE - am 15.10.2016 15:17
Hi Bart, I'm sorry about that, no offence meant! We've had this problem on our own. One of our employees' WD-dongle was broken and got a replacement. Means, he had to wait for about two or three days for return of the good dongle. The guy had to urgently fix a problem and in his need he thought he could use a cracked WD. When the new dongle arrived, WD crashed all the time, no cure possible. In the end, the hard disk had to be reformatted and Windows had to be re-installed. Then the dongle worked fine again.

von GuenterP - am 15.10.2016 15:50
@ Guenter : no problem

I reverted my PC to the Windows10 version before the anniversary update, and now the problem is solved, Windev generates executables again. So it has definitly something to do with this Windows update.

One strange thing however : when I start the generation wizard, Windows shows a popup to insert a smartcard. Pressing cancel, this popup disapears, but it is showing for another three times, but after cancelling it all the times, I can finally generate my exe.
Anyone any idea where this comes from and how to avoid it ?



von Bart VDE - am 16.10.2016 11:26
Hi Bart, great, it works again! Can't imagine what this weird smartcard thing means. As I told you, I can run WINDEV17 (with a v22 dongle + driver, that may be the difference) on my Windows 10 PC without problems. I recommend to send a report to PC Soft's Tech Support anyway, maybe they have a solution?

von GuenterP - am 16.10.2016 13:55
Bart, pleased to hear you are operational again.

I have just generated a v17 project without any issue.

Not sure what version of Windows 10 I am on but the info I can see is......

Edition Windows 10 Pro 64bit
Version 1607
OS Build 14393.321
Product ID 00330-80000-00000-AA570

Dongle is v21

von DerekT - am 16.10.2016 17:18
Hi Bart,

I had this 'Smartcard' question also in the past. I can't remember if it was in WD17 or later. It caused no problem, except that I had to click away the popups.

Maybe it is related to some BE-ID drivers? (http://eid.belgium.be/)

Kind regards,

Joris.

von Joris - am 17.10.2016 11:36
Hello Joris,

Thanks for the hint. It could be possible since this ID card driver is installed on my PC.
I'm gonna test it if it still shows the popup after I remove the driver.

Bedankt,
Bart

von Bart VDE - am 18.10.2016 06:33
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.