Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
14
Erster Beitrag:
vor 12 Monaten
Letzter Beitrag:
vor 12 Monaten
Beteiligte Autoren:
SolutionJ-Reg, Arie, Peter Holemans, Robert Willis, Joris

Generate Executable hangs

Startbeitrag von SolutionJ-Reg am 22.11.2016 10:00

WD15

Hi everyone,

I have WD15, WD18 and WX20 loaded on my laptop, have done for months with no problem. Then, out of nowhere, if I try and generate a 32-bit executable in WD15 it hangs at 48%! If I generate a 64-bit executable in the same project it works ok.

Any ideas would be much appreciated, I'm scratching my head here. I've tried clearing the cpl library to no avail.

Kind Regards
Reg

Antworten:

Hi,

Close the project and in the 'Exe' directory clear the 32-bit configuration output folder. Also clear you .cpl directories in the project. Reopen the project and regenerate your 32-bit configuration.

Cheers,

Peter Holemans

von Peter Holemans - am 22.11.2016 10:23
Hi Peter,

Thanks. I've looked in the exe folder and there doesn't seem to be any sub folder?

von SolutionJ-Reg - am 22.11.2016 10:52
Update...

I let the Execution generation run for about 20 minutes, then ended the task, checked the EXE folder and found an executable file had been created, but if I try and run it I get the error message "This program was created with a version of the WINDEV Framework more recent than the version found on this computer"?

von SolutionJ-Reg - am 22.11.2016 11:35
Hi,

Did you recently installed any updates of WD?
I have had some kind of the same problem after an update of some WD20 dlls from PCSoft support. The solution was to restart Windev just before the creation of the executable.

Kind regards,

Joris

von Joris - am 22.11.2016 13:30
Hi Joris,

No updates that I'm aware of. I have tried restarting Windev and then immediately trying to create the executable to no effect I'm afraid.

Thanks
Reg

von SolutionJ-Reg - am 22.11.2016 13:35
Hi,

Can you review your build options and choose: include the framework in the executable ?
That should already solve any runtime issues between the framework installed in your common programs on your computer (probably by testing an installation of one of your previous written WX programs) and the framework of your development environment.

Cheers,

Peter Holemans

von Peter Holemans - am 22.11.2016 14:33
Hi Peter,

Good idea, just tried it but no success. I've also uninstalled WD18 and that's not helped either.

Nightmare ...

von SolutionJ-Reg - am 22.11.2016 15:54
Can you genereate one of the example projects? So see if it is wd15 of something in your project.
Maybe you can upgrade the project to WD18 or even WD20?

von Arie - am 22.11.2016 16:22
Hi Arie,

Just managed to create an executable using one of the example projects, so it seems the project is restricted to my project. Upgrading to WD18 or whatever is an idea, but it's not something that I can do overnight and this application is live with several customers, so I really need to fix it another way if I possibly can.

Thanks for the idea.

Cheers
Reg

von SolutionJ-Reg - am 22.11.2016 19:01
Another option would be to create a new empty project and import all windows, reports, etc into it. Maybe in some smaller portions like 25 or 50 windows at a time or something like that.

von Arie - am 22.11.2016 19:09
By any chance did you hook up another monitor (external). This happened to me once. Turned out a pop up was on an external monitor that was no longer there.

von Robert Willis - am 23.11.2016 04:32
Hi Arie,

Yes, tried that, same error. I did also restore the previous version of my system though, and that worked, so there's something I've changed very recently that's actually causing this. I'm going to use the Comparator tool to try and zero in on the offending code/window or whatever.

As ever, thanks for the input.

Regards
Reg

von SolutionJ-Reg - am 23.11.2016 06:17
Hi Robert,

No external monitor involved, but thanks for the input.

Rgds
Reg

von SolutionJ-Reg - am 23.11.2016 06:17
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.