Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 1 Jahr
Letzter Beitrag:
vor 1 Jahr
Beteiligte Autoren:
SolutionJ-Reg, JP, Al

Extremely weird but it might be of interest

Startbeitrag von SolutionJ-Reg am 27.11.2016 12:16

WD15

Morning everyone,

About a week ago I put up a question about the fact that all of a sudden I could not generate an Executable for my project. This was very worrying because I have several customers using this system.

Some good advice was given and I followed it all, and in fact it's only this morning I finally rebuilt the project library by gradually importing, compiling and backing up chunks of objects at a time.

So, I was almost in tears when, all of a sudden, the same thing happened. I could not believe it. Between the last successful executable build this morning and the first one to go wrong again the only thing I had changed was the version number. The last working one was 36.15.1.7, but having set it to 42.0.0.0 the Executable creation started freezing again.

In desperation I tried again, this time setting the version to 43.0.0.0 and .....
It worked!

So, for some reason for which there cannot possibly be a reasonable explanation, the version 42.0.0.0 seems to cause the Executable creation to freeze, at this for this project.

Bizarre? Weird? I'm lost for words, except that I've just spent 5 days rebuilding my system when I only needed to change 1 digit in the version and try again.

So if any of you ever have problems generating an executable, I strongly suggest you try changing the version number first.

Cheers
Reg

Antworten:

Hello Reg

Interesting info but not that I want to test it out :)

My prime version number keeps pace with the Windev version the software was compiled for so at the moment my producttion release is 20.1.289.0, so I won't run into the problem you describe for another 22 years, by which time - hopefully - it is not an issue anymore.

Regards
Al

von Al - am 27.11.2016 22:30
Reg,

This is a wild guess but it might be that your exe with that version number matches a virus/malware signature (have seen this before) and then your AV interferes with the generation. Worth a quick review I guess...

von JP - am 28.11.2016 05:38
Hi JP,

I guess that's a possibility, who knows. It's spooky that the number giving me the problem is 42 (Hitchhikers Guide to the Galaxy)...

von SolutionJ-Reg - am 28.11.2016 08:38
lol! Great books :)

I once had this problem and just changing a couple of bytes in the exe changed the "signature" and all was OK again. Painful to find out though!

von JP - am 28.11.2016 09:43
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.