Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
12
Erster Beitrag:
vor 10 Monaten, 2 Wochen
Letzter Beitrag:
vor 10 Monaten, 1 Woche
Beteiligte Autoren:
Ola, Noel Tanti, Arie, GuenterP, Harry W

[WD21] HFSql + Native access = showstopper?

Startbeitrag von Ola am 08.01.2017 19:37

Hi ALL

I was doing some totally innocent improvements in my ERP's salary system, When I started to have problems when testing it: under certain condition A certain button code was not executed, under some other condition it was.

OK, I thought, no big deal, WD has just lost its marbles again, so it's time to clear WD's thoughts by deleting the .CPL directory. So I saved and closed the app, and deleted the app's .cpl directory.

Then I re-opened the app, and voilà, A brand new compilation error appeared that I have never seen before:

"The project is using native accesses, which is not available in integrated framework.
Appname, , line 1, column 1"


Obviously I am using native access, because the data is in HFSql (Classic) data files,
but it's rather weird error message, considering that this happens in testmode...

Recompiling does NOT help.
Running the app repair process does NOT help.
Restarting Windows (7) does NOT help.

Anybody seen this? What could it mean? How can I get rid of this nasty showstopper?

Best regards
Ola

Antworten:

In Windev you use 'native access' when you want to work with databases like MSSQL, MySQL, Oracle etc etc,

Why do you use 'native access' for HF (.fic) tables ?
Maybe I don't understand you ?

von Harry W - am 08.01.2017 21:19
Hi Ola,

this is for connecting to a HFSQL C/S database:


// Start Connection & read directories into HFCSDatabaseName-Combo !
MyConnection..User = NoSpace(AdminName)
MyConnection..Password = NoSpace(AdminPW)
MyConnection..Database = ""
MyConnection..Server = NoSpace(ServerAndPort)
MyConnection..Provider = hAccessHFClientServer //


von GuenterP - am 09.01.2017 06:52
Hi Ola,

maybe there's an old connection in the analysis itself which is defined as 'native'?

von Arie - am 09.01.2017 07:19
HI Ola

I get that error when compiling and selecting the 'Framework included in the executable'.
This is phase one,5th step (Framework)

Hope this is it.
Regards
Noel

von Noel Tanti - am 09.01.2017 11:42
Hi all

Thanks for the replies.

@Harry W: I am not specifically using 'native access' for HF (.fic) tables. I just suppose that WD itself is using 'native access' to access the files, when I am using commands like HReadSeekFirst, HAdd, HModify, HDelete etc..

-@Arie: there are no connections made, ever, at least not by me. If there is, it is secretly done by WD. I have always used just plain HFSQL (Classic) files directly and defined the "database" by using HSubstdir commands to replace the default directories defined in analysis.

@Guenter: Thank you for the connection samples. But, like I said above, I am using HSubstdir instead of using connections. Should I be using connections like in your example? What are the benefits over just using HSubstdir?

I am totally flabbergasted with this. I had changed nothing related to the process of connection to my "database", which has been HSubstdir for the last 17 or so years.

The error came out of the blue, after I had deleted the app's .CPL directory, in order to get rid of a weird problem in a button code (as explained in the beginning of this thread), and is now there, cannot be got rid of, and warns me every time I run a test, or compile the program. It doesn't seem to have any ill effects during run time, but I can't be sure, can I?

I even deleted the problematic button and rebuilt it, but it has no effect.

I think this just one of the snakes that is keeping its nest under the bonnet of WD, poking its head upwards and seeking for something to strike next...

Best regards
Ola

von Ola - am 09.01.2017 12:00
More info about the error:

This is a new type of error, that I haven't seen before, and cannot find any documentation for.

The well-known 4 different error types (code, warning, info, gui) are documented here:
http://doc.windev.com/en-US/?3084022&product=WD

But this one has a different icon: a white gear on a red square. So what error type is this?

Best regards
Ola

von Ola - am 09.01.2017 12:46
Hi all,

A weird thing happened. Yesterday, at approximately 16:00 hrs Finnish time, the
"The project is using native accesses, which is not available in integrated framework.
Appname, , line 1, column 1" -error disappeared, as mysteriously as it first appeared!

I had been stubbornly continuing my normal development, and cranking out new exes,
to see whether they worked correctly, and then, suddenly, the error vanished back into
the blue where it originally came from.

And I had done nothing related to the error message!

My trust in WD is currently not much above zero. It seems to be more like a random
error generator rather than a serious programming tool.

Best regards
Ola

von Ola - am 10.01.2017 12:00
Hi all,

Guess what? This funny error

"The project is using native accesses, which is not available in integrated framework.
Appname, , line 1, column 1"


came back today at approximately 15:30 hrs, after I had been struggling with the report editor for a couple of hours, trying to add a few columns and change their position. Seems to be a hopeless effort. I may have to build the report again from scratch.

I must say that I wouldn't have the guts to supply this kind of crap to anybody, not even free of charge.

Best regards
Ola

von Ola - am 11.01.2017 13:43
Hi all,

The error message is still there, but I found a way to edit old reports, specifically to add columns and move them to the appropriate place:hot:. The hints:

- Working inside the report table (all cells selected) I found that columns cannot be inserted to the correct place. This will create a mess and a white, empty column. No good.

- Working inside the table, columns can be added, to the end of the table, with the add key, but they cannot be moved with the KeyToLeft or KeyToRight buttons, that obviously are meant for this purpose. This will create a mess by changing the labels of columns randomly! No good!

- The newly added columns can be moved, working from outside the table, by selecting the column (two clicks on one of the header or data cell of the column), then right clicking and selecting from the pop-up menu the move to the left or move to the right command.

Best regards
Ola

von Ola - am 11.01.2017 14:32
Hi all,

The
"The project is using native accesses, which is not available in integrated framework.
Appname, , line 1, column 1"

-error disappeared again, when I opened another app at the same time as the "problem app".
Very weird.

Best regards
Ola

von Ola - am 16.01.2017 10:55
Hi all,

WD's random error generator seems to work very reliably.
This error came back againg, after the "pinball"-Wd had gone to "tilt".
This time I could not get rid of it with the trick I described in the previous message.

Best regards
Ola

von Ola - am 17.01.2017 13:37
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.