Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 8 Monaten, 3 Wochen
Letzter Beitrag:
vor 8 Monaten, 3 Wochen
Beteiligte Autoren:
Piet van Zanten, Alexandre Leclerc

[WB21] period in url rewriting [solved]

Startbeitrag von Piet van Zanten am 31.01.2017 14:35

Hi,

I'm using the Webdev url rewrite feature and it did look promising at first.
I'm using the parameter button to create an automatic link url in a looper.
But now I'm having a problem when part of the generated url contains one or more periods (.).
Apparently the browser (or webdev?) considers the part after the period to be the file extension and a Not Found error is displayed for the requested page. If I remove the periods the page shows ok.
So if the url is "http://www.mysite/info-123456-Some brand-Some article hxb 12.5 x 23.4 with battery included.awp" it is not found.
Where 123456 is the real parameter and the other two parts are only supplied to make the url seo friendly.
I tried to urlencode the period to %2E manually, but then Webdev urlencodes the % sign on top of that, making the url invalid too.

Any suggestions?

Kind regards,
Piet

Antworten:

Re: [WB21] period in url rewriting

Hi Piet,

Can you, or are you able to simply strip (or replace) the punctuation from your “SEO-friendly” URL part? That would be a simple fix. Normally a period can be used in an URL and using %2E would defy the purpose of having an SEO-friendly URL. Make sure to report the bug and meanwhile if you can replace the period with a coma, for example, maybe it could help.

Best regards,
Alexandre Leclerc

von Alexandre Leclerc - am 31.01.2017 14:51

Re: [WB21] period in url rewriting

Hi Alexandre,

I did try the comma, but that also seems to break the url.
The best option for now would be to just leave out the period and measure in mm instead of cm.
I'll report it, but I'm afraid they will ask for a project again.
Recently I sent 3 lines of code and they could not handle it without a project.

Best regards,
Piet

von Piet van Zanten - am 31.01.2017 15:24

Re: [WB21] period in url rewriting

Hi,

It was my bad, I set the "format" option that creates the regular expression to alphanumeric, while I should have chosen "none".
Now it works fine.
So in fact it's an awesome feature :spos:

Best regards,
Piet

von Piet van Zanten - am 31.01.2017 19:00

Re: [WB21] period in url rewriting

Super!

Best regards,
Alexandre Leclerc

von Alexandre Leclerc - am 01.02.2017 18:43
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.