Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 9 Monaten, 3 Wochen
Letzter Beitrag:
vor 9 Monaten, 3 Wochen
Beteiligte Autoren:
ccc2, Ruben Sanchez Peña, Al

[wm21 - android] How to set minimun version required to run

Startbeitrag von ccc2 am 18.02.2017 05:30

Hi,

I doing test my app on android 7.1 . I had update the sdk . in WM21 advanced configuration I can select sdk use to compile to 7.1.1 but I can't set the minimum version required to run to 7.1 on drop down menu show up to android 6.0 only

Antworten:

Hi. You can change the SDK versions in app manifest.

Rubén

von Ruben Sanchez Peña - am 19.02.2017 21:23
Thanks ,

found it at advanced configuration -> edit manifest .


but is there a way to add it into the combobox of minimun version to run android ?

von ccc2 - am 20.02.2017 09:23
Hi. I don't understand why you need run your app only on Nougat devices. Setting the Min SDK version to 25 value restrict your app to 7.1.1 devices and the app will not install on previous version devices...

Advantages?


Rubén

von Ruben Sanchez Peña - am 20.02.2017 12:46
it's requirement for the testing that I running to ensure my app has no problem running on nougat and only run on nougat device.

this way in case if there any problem , i will just make change on it without messing with the current version

von ccc2 - am 20.02.2017 16:03
Hello ccc2

Can you use the SysAndroidVersion() function to test the device operating system when it starts and display a message and then stop if the version is lower than 7.1.1

Regards
Al

von Al - am 20.02.2017 16:16
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.