Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 4 Monaten, 3 Wochen
Letzter Beitrag:
vor 4 Monaten, 3 Wochen
Beteiligte Autoren:
Erik Schwarz, Fabrice Harari

[WD20] TableSave not working

Startbeitrag von Erik Schwarz am 01.04.2017 16:02

Hi,

what I'm doing since years, now isn't working on one of my tables.

Table is filled by a query
Columns are linked to the query fields
Automatic save when leaving a row is on.

No saving in the file occurs, even if I add 'Tablesave' in the row Exit code.
The code is executed (checked with Debugger).

deleted cpl-folder with no success, same with Project repair ...

Any ideas what may have happened?

Erik

Antworten:

Re: [WD20] TableSave not working -SOLVED but why

Hi,

just had an idea.

In the initalization code I included:

HExecuteQuery(QRY_xyz,hModifyFile)

Now it works, but why does it not work in the other case?

Erik

von Erik Schwarz - am 01.04.2017 16:07

Re: [WD20] TableSave not working -SOLVED but why

Hi

AFAIK, because the hmodifyFile is the only way top indicate that hmodify/tablesave is authorized on the query

Best regards

von Fabrice Harari - am 01.04.2017 21:07
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.