Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 2 Monaten, 1 Woche
Letzter Beitrag:
vor 2 Monaten, 1 Woche
Beteiligte Autoren:
André Labuschagné, Ola, Al, Fabrice Harari

[WD21] Windev makes project directory invisible!?!?!

Startbeitrag von Ola am 11.07.2017 12:08

Hi all,

Has anybody else experienced this:

Sometimes (not very often, luckily), Windev makes a project directory (or its sub-directory) invisible!

This seems to happen especially when opening a new project directory that Windev has not been in touch with earlier. This happened today:

I first did a clean install of the latest A360ERP to see whether is has something interesting.

Then I tried to open it by doubleclicking its WDP file in Total Commander file manager.
It tried to open with WD19, so I closed the WD19 opening window, because I know this app is in WD21 format. Why did it want to open in WD19?

Then I dragged the WDP file on top of the WD21 icon on the desktop. It opened normally, but at the same time the app's directory became invisible. And stayed that way when I closed WD21. Or maybe the directory became invisible when it was touched by WD19, I am not sure.

Earlier there have also been cases when my own many years old ERP's development directory, or some of its subdirectories, have become invisible.

I have a batch file that checks the whole partition and removes the invisible flags, but this takes "ages" (some 15 minutes or so) when it goes throug all the directories on the partition, like this:


attrib -h -r -s *.* /s /d


I don't like to play more with this problem, because it takes so much time to recover from invisibility, so I'm asking whether anybody has some more exact info about it.

Maybe it is caused by WD19? Maybe I should remove the WD19 installation?

Best regards
Ola

Antworten:

Hi Ola,

it never happened to me, but I've heard about the problem for people using the SCM.

Are you?

As for WD19, I do NOT think that this has anything to do with it, as I have all versions from 15 to 22 (+ 7.5) both in French and US installed on my development machine.

Best regards

von Fabrice Harari - am 11.07.2017 19:35
Hi Ola

Not invisible but read only. Have not seen it often.

My solution - rename the project folder in question. Create another folder with the name of the original folder. Cut and paste the contents of the renamed folder into the new folder. Delete the renamed folder.

This always works. Do not use SCM but have heard of this read only behaviour from SCM users.

Down and dirty and it works. I have no idea what causes it.

Cheers
André

von André Labuschagné - am 11.07.2017 21:16
Hello Ola

I can remember something like this from a few years ago when the project directory was invisible to things like Teamviewer. I think it was something weird to do with the graphic that PCSoft used to display the folder and changing the folder graphic fixed the problem.
I am embarrassed to suggest this because it sounds so crazy, but changing the folder graphic in the properties can't hurt to try.

Regards
Al

von Al - am 11.07.2017 21:28
Hi all,

thank for your experiences.

I am not using SCM. When I gave some more thought to this "phenomenom", and the situations where I have experienced it, I came to the conclusion that, when it happens, it might have something to do with the different versions of the app and WD.

Best regards
Ola

von Ola - am 11.07.2017 22:00
Hi Al

Teamviewer is not a crazy idea for playing silly buggers with graphic cards and IDE behaviour. And this is not restricted to the PCSoft offerings.

Something to consider.

Cheers
André

von André Labuschagné - am 11.07.2017 23:03
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.