Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
4
Erster Beitrag:
vor 4 Monaten, 1 Woche
Letzter Beitrag:
vor 4 Monaten, 1 Woche
Beteiligte Autoren:
Alexandre Leclerc, Ccc2, ccc2

[WM22 - android] HttpRequest() not working for self signed certificated

Startbeitrag von ccc2 am 14.07.2017 04:34

Hi ,

in pre version 22 , I can get it work by install root certificated in my android device .
but now, it keep give me error "the remote certificate cannot be authenticated" (httpErrorInvalidCertificate:)

i have tried added HTTP.IgnoreError = httpErrorInvalidCertificate but no use, and then i tried add all available httperror in http constant . still get same error

what should I do , any suggestion ?

Antworten:

Hi ccc2,

Even a good self-signed certificate should work. Are you sure your certificate is still valid? (They have dates of validity, etc.) Have you tried from WinDev of WebDev just to rule out a device specific issue? (It could be the case, as you suggested.)

Best regards,
Alexandre Leclerc

von Alexandre Leclerc - am 14.07.2017 12:32
Hi Alexandre,

Yes. It work on app that I compile using wm21.

von Ccc2 - am 14.07.2017 13:04
Hi Ccc2,

Sounds like a call to the tech support. :S

Kind regards,
Alexandre Leclerc

von Alexandre Leclerc - am 14.07.2017 14:03
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.