Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 4 Monaten, 1 Woche
Letzter Beitrag:
vor 4 Monaten, 1 Woche
Beteiligte Autoren:
DerekM, GuenterP

[WB22] - LoadDLL no longer working [RESOLVED]

Startbeitrag von DerekM am 15.07.2017 03:54

This is complex DLL Hell issue - and there is no workaround.

WD19 was able to load a critical "64 bit"dll - [webdev dynamic application running on IIS8.5 on Windows 2012 R2 standard (64 bits)].

Now the same code - same environment - throws an error "..dll is not a valid Win32 application". Note: this is an API interface - I have no access to the DLL code.

I have rolled back recent Windows 2012 patches and tried just about every permutation that I can think of - but it is starting to look like something fundamental has changed in the wd220vm.dll.

Everything works fine on Windows 10 development mode, so it may be related to the way wd220vm.dll code handles the Win 2012 environment (i.e. finding the dll but not the associated .lib file).

At the moment I am pretty much out of ideas, so if anyone has any experience with LoadDLL or can throw-in any suggestions for an approach to track this down it would be greatly appreciated.

I doubt that PC Soft support would be able to help unless I can replicate this with a simple application and some generic dll - but that is a long road.

Anyway - if anyone has any ideas or suggestions ...

Thanks

Regards,
Derek

Antworten:

Re: [WB22] - LoadDLL no longer working

Hi Derek,

one thing's clear: a 64-bit DLL will not work in a 32-bit application. 32-bit apps do need 32-bit DLLs and 64-bit apps will need 64-bit DLLs. If it worked for you to match a 32-bit app with a 64-bit DLL then, as it seems, you had lots of luck - your needed DLL-functions were indeed 32-bit.

Only way: switch your app to 64-bit - then you will be able to include this specific 64-bit DLL.

However, if you can find a 32-bit version of the DLL then you can compile a 32-bit app as you wish.

von GuenterP - am 15.07.2017 04:42

Re: [WB22] - LoadDLL no longer working

Hi Guenter

Yes. Exactly! I have just fixed the problem before reading your note.

I *thought* that I was running the 64 bit application server - but re-installed it - and the 64 bit dll's are now there and being picked up.

I don't know why - but I must have inadvertently installed the 32 bit application server.

Whew! (there is no 32 bit API dll available)

Thanks for your help.

Regards,
Derek

von DerekM - am 15.07.2017 05:08
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.