Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 1 Monat, 2 Wochen
Letzter Beitrag:
vor 1 Monat, 2 Wochen
Beteiligte Autoren:
JP, Fabrice Harari

[WB21] - Copying a site to a new server

Startbeitrag von JP am 23.10.2017 12:20

Hi All

I have a problem with trying to move a site from an existing and working Windows Server 2008 to a new Windows Server 2012.

I have installed the WebDev Administrator, Control Center, etc. I have set up the required user and it has created the IIS user account, the admin account, etc. I have copied the folder from the old server to the new server. I have create the website under IIS and pointed it to the WebDev folder. I have setup all the same settings and permissions from the old server on the new server.

When deploying to the old server all works fine.

When deploying to the new server it uploads the ZIP file and then stops with the following message:

...Searching for an existing site
...A site with the same name is already installed on the server
...The same server cannot host two sites with the same name
...Use the WebDev Administrator or the Remote Administrator to rename your site or uninstall the existing one
...If it is the same site you must perform a site update (instead of a site setup)


Here I am stuck. If I delete the existing site from IIS then I get another failure which is "serve replied with unexpected event" or something like that with no useful info.

I have searched the dialogs of the deployment process but cannot find an option "update" vs "site setup" as suggested in the red error message above.

Not sure how to resolve this. Any help appreciated.

Thanks

Antworten:

Hi JP

it looks to me that your mistake was to try and mix manual setting and automatic one.

You say that you copied the site directory from one machine to the other, while you should have just installed/deployed the site on the new server.

So now, SOME things are set bu you, but not everything (or not correctly) and when you try to deploy, you get an error.

Normally, I would:

Setup the server, setup IIS, install webdev 22 engine that would configure IIS for me and the way it likes it, complete the configuration manually (ftp and permissions setting, mostly) then deploy the site on the new server (and certainly not copy it manually, or create it manually in webdev)

Best regards

von Fabrice Harari - am 23.10.2017 13:25
Fabrice

Thanks (as always).

1) I have removed the web folders I copied from WebDev on the originals server. Only the parent "WebDev Hosting" folder exists.

2) I have reset the IIS website for the domain name to point to a basic www folder on the server

3) I have told the WB Admin user account to use the website set up above

4) Now it just transfers the setup zip file and then an error message:

"The process of the request was interrupted by the server in an unexpected way"

Any further suggestions for me?

von JP - am 23.10.2017 13:48
Hi again

on the server, via remote control, run the webdev administrator. IN the advanced tab, run the server and diagnostics functions to make sure that webdev engine is happy with all the settings. If not, use the correction buttons.

Once that is done, in the webdev (editor) deployment process, make sure to use the TEST button to verify that both ftp and webdev settings are correct from that side.

Best regards

von Fabrice Harari - am 23.10.2017 14:50
Fabrice

Thanks, this helped me find the problem. Please check your PM.

von JP - am 23.10.2017 15:20
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.