Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
12
Erster Beitrag:
vor 1 Monat, 2 Wochen
Letzter Beitrag:
vor 1 Monat, 2 Wochen
Beteiligte Autoren:
JP, Piet van Zanten, Fabrice Harari, Danny Lauwers

[WB21] - Deploying a site

Startbeitrag von JP am 24.10.2017 06:47

Hi All,

I'm setting up a new server Windows 2012. I have 3 simple sites which are all dynamic and basically variations of each other (i.e. same layout, code, etc. just some content is different). With Fabrice's help I have managed to set up 2 of them and they work fine. The 3rd one gives me an error in the deploymemt. Here is what I have done and its the same steps that I did for the first 2 sites which worked fine.

1) In WB Administrator set up the user account.
Both accounts are created i.e. the user account and the IUSR account
Both are correctly added to the FTP group
The site folder is created in the WebDev hosting folder
The site in IIS is set up with virtual folders for WB

2) Under WB Administrator the server diagnostic checks OK

3) Under WB Administrator the server -> virtual servers shows the sites for whcih WebDev must be installed OK

4) IIS shows the WB virtual folders under the site domain

5) At this point, under WB Administrator the new site does not show under the Sites tab.

6) I then run the WebDev deployment on my computer

All logins check OK
The deployment starts, the zip file is sent to the server
The zip file is extracted and additional folders are created in the correct place
Then the status windows in WB appears with 3 error lines which read:

(info icon) Registering the site in the administrator
(error icon) Failure saving the application in the account file
(error icon) Check whether the permissions on the files are correct (or contact admin...)

7) The site does not appear in WB Administrator (obviously)

8) As far as I can see the folders have all the right permissions as does the IIS site.
The correct users are allocated to the folders and IIS domain.
It all looks the same as the other 2 sites which work fine.

9) Clearly it is failing due to permissioning but I dont know where to look or why the same steps worked before and not now.

Any help appreciated. Thanks.

Antworten:

Hi JP,

I think I know that one...

When the error is >>Failure saving the application in the account file

von Fabrice Harari - am 24.10.2017 10:53
Fabrice

Thanks. The account directory and indeed the entire WebDev 21.0 directoyr has the WebDev FTP user permissioned with full rights. Should I add the site user account to the permissions perhaps? But that would beg the question why the other 2 sites worked fine even without have the site user added ... ?

von JP - am 24.10.2017 12:42
Hi Fabrice

I tried adding the WinDev site user to the permissions on the ACCOUNT folder but the problem persists. I even tried re-creating a new site user and thus a new folder structure in the WebDev hosting folder but that didnt work either. I cant fathom why the 2 other sites upload/deploy every time but this one site refuses to complete...

von JP - am 24.10.2017 17:27
HI All

Tried everything I can think of and this one site will not deploy. Keeps saying:

(info icon) Registering the site in the administrator
(error icon) Failure saving the application in the account file
(error icon) Check whether the permissions on the files are correct (or contact admin...)

... even though 2 other sites which are almost identical do upload/deploy fine from the same source development computer (my own). I have deleted the WebDev accounts, deleted the IIS website, recreated everything and still no luck with this one site.

I have sent PCSoft a support request but heard nothing so far.

I am now open to anyone who wants to quote me to try and figure it out - you can PM me. Thanks.

von JP - am 25.10.2017 09:18
Hi JP,

As an alternative you could try using a setup by physical medium.
It creates a setup program that you can run on your server.

Kind regards,
Piet

von Piet van Zanten - am 25.10.2017 14:39
Hi Piet

Could you give me some more guidance on how to do that? Appreciate any help.

von JP - am 25.10.2017 15:04
Piet

Just to be extra clear - the WebDev deployment process uploads the site's WebDev ZIP file and extracts it to the right places - all the folders and files are there - but it fails to register the site in the administrator with the following error:

(info icon) Registering the site in the administrator
(error icon) Failure saving the application in the account file
(error icon) Check whether the permissions on the files are correct (or contact admin...)

So its the last step that it fails on. But 2 other sites coming from the same development computer do upload/deploy perfectly over and over again. Just this one site refuses to register ...

von JP - am 25.10.2017 15:09
Hi,

Have you setup security on registry ?
Because when a site is registered, it writes to the Windows Registry .

Danny

von Danny Lauwers - am 25.10.2017 15:38
Hi Danny,

I dont know what security to setup on the registry. The other two sites which I set up in the same way have not needed me to do anything in the registry but I'm willing to give it a try if I know specifically you refer to?

Thanks

von JP - am 25.10.2017 15:54
Hi

the specific key to manage in the registry is listed in the pdf document coming with the engine.
The FTP user should be given write permissions to this key.

I did not mention it because I don't see how you could install other web sites if that step was not done.

von Fabrice Harari - am 25.10.2017 18:32
Hi JP,

It's the option after deploy remotely "create a physical media setup".
You can run the exe it produces as administrator on the server so perhaps it can overcome possible rights issues.

Kind regards,
Piet

von Piet van Zanten - am 25.10.2017 19:16
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.