Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
4
Erster Beitrag:
vor 1 Woche, 3 Tagen
Letzter Beitrag:
vor 6 Stunden, 13 Minuten
Beteiligte Autoren:
Ola

[WD23] Report editor

Startbeitrag von Ola am 14.06.2018 09:41

Hi all

I have been pleasantly surprised by the stability and well-functioning of the current version (23) of the report editor. I can now actually modify old reports without the cold ring around my sitting muscles that it's all gonna go bezerk any minute, like a a touch with the mouse in a wrong place and suddenly it's all messed up. Not any more. Even the editing of the field outlines work now as they should.

Still, there are occasionally weird GUI errors, like:
"Error:The data source of the report references an element not found in the project or analysis.File: SOUSREQUETE_FROM_1BED0F20)
R_Maksut_In_R1_ALV, , line 1, column 1"

When I go and check the links of the fields, they are all lost, and replaced with a link to text:
-- Obviously, if the fields are searched from "SOUSREQUETE_FROM_1BED0F20", when the actual file used for this report is a query named "Q_MAKSU_R1_ALV".

Still, the report seems to work as it should!

I've seen this error a couple of times, and if I re-link the fields, the report editor will soon mess them up again.

While wasting my time with this, I noticed that it would be nice to see the name of the field also in the Link tab, and not have to jump back and forth between the General and the link tab to make sure that the correct report field is being linked to the correct file/query item.

Anybody else experienced this?

Best regards
Ola

Antworten:

I just tried to re-establish the links that the Report editor had lost, but now, the query items are not selectable at all!

Ola

von Ola - am 14.06.2018 17:18
OK,

I ran the Repair process for the app, and it brought back the correct links in the report fields, but it did not delete the error! The error disappeared only after I had gone through each field separately and updated them!

So there are still snakes under the bonnet, but generally, the current version of report editor works briljantly after having been badly defected for so many years and versions. I can now even adjust the width of the columns with mouse!

von Ola - am 15.06.2018 11:33
Hi again,

I have to take back some of the praise I gave to the new report editor. It still has a lot of worms to be fixed. I just got some more white hair adding a field to an old report and then moving it to its correct position. The columns and their headers lost each other and ended up in wrong places. Also when trying to adjust the column width within the table (not at the end of it) seemed to mix up the table. So I did not update the chances, but instead pressed Control-Z to cancel the changes, and now, surpise, voilà, everything was as I wanted it to be. So, for now, end is well, all is well. But I wonder, how many versions they need to fix the report editor so that it works reliably.

I wish the hungry looking girls in their brochures would for once say that NO, we won't pose for you untill you fix your product!

Best regards
Ola

von Ola - am 24.06.2018 19:58
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.