Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
elweb Technik
Beiträge im Thema:
24
Erster Beitrag:
vor 1 Jahr, 7 Monaten
Letzter Beitrag:
vor 1 Jahr, 7 Monaten
Beteiligte Autoren:
Bernd Schlueter, `helmut`, rostefix, Hotzi-47, R.M, el3331, wotan,der ältere

Berlingo Ladestrom/Ladespannung anpassen

Startbeitrag von Hotzi-47 am 02.04.2016 14:16

Hallo rostefix,
Dein Wunsch sei mir Befehl. Also mal ein neuer Thread mit korrektem Betreff.

Zitiert aus dem anderen Thread:
Hallo Klaus, zu Deinem Beitrag über Unterschiede Ladegerät Saxo / Berlingo # NEU, geschrieben von: KlausA am 02. April 2016 14:41
Hallo Roland, du kannst nur den Ladestrom aus der Netzladung einstellen. Aber ich kann grob auf 8 / 10A Netzseitig einstellen. Grüsse Klaus


Ja danke, genau so hatte ich es mir schon gedacht. Deine Lösung ist ja auch für (D)ein anderes Problem gedacht, nämlich bei Netzladung die Li-Akkus nicht zu überladen. Elegante, wenn auch etwas aufwendige Lösung. Na ja, wenns schon fertig ist..

Ich wollte - wie in einem anderen Thread schon mal beschrieben - das Ladegerät von max. 16A Eingang auf max. 10A Eingang vom Netz umschalten. Z.B. Laden in Deutschland an 16A Dosen, in der Schweiz und Italien an 10A Dosen. Bernd hatte das jeweils per Lexia und Software gemacht. Geht sicher zur Not gelegentlich, doch ein kleiner Schalter wäre im Betrieb einfacher. Wo könnte man ohne grossen CPU Aufwand mit ein paar Bauelementen plus Schalter sowas in die SAGEM Box reinbasteln? So eine Lösung wünsche ich mir noch immer für Berlingo und AX, habe beides.

Ebenfalls Ladestrom anpassen oder besser Ladespannung begrenzen bei der REKU hatte ich mir vom System mal anders gedacht, mangels wirklicher Notwendigkeit aber noch nicht verwirklicht. Wäre nur bei Li-Umbau wirklich bitter nötig geworden, aber der steht noch an für später. Die Akkus, die ich gerne hätte, bekomme ich noch nicht, Stichwort entweder von Kreisel die 18650 mit Wasserkühlung und/oder die Litarion aus Kamenz mit 9000 Zyklen.

Aber hier meine Gedanken zur Spannungsbegrenzung mit der Bitte um Kommentar, falls sowas schon mal gebaut worden ist:
Man messe die Gesamtakkuspannung. Wird die zu hoch bzw. ist der Grenzwert erreicht, wird das Fahrsignal so beeinflusst, dass weniger oder gar kein Rekustrom mehr fließt. Also muss unten am Fuss-bedienten Poti-Signal eingegriffen werden.
Klar, dass bergab nicht mehr über Reku gebremst wird und der Wagen immer schneller wird. Dann mechanisch über das Bremspedal bremsen. Mist, dann springt wieder die Reku an. Also muss auch hier das Signal von der Bremse hin zur Sagem unterbrochen oder so beeinflusst werden, dass die SAGEM nix von der mechanischen Fussbremse merkt.
Vorteil dieser Lösung wäre, dass man die Sagem Box eigentlich nicht öffnen müßte.

Weiterer Vorteil wäre, dass man dann weitere Funktionen in die Box, die das Fahrsignal vom Poti "verbiegt" einbauen könnte: Begrenzung auf max. Fahrstrom, Begrenzung auf max. Rekustrom, Tempomat (sofern man die Geschwindigkeit als Messgröße vorliegen hat) und so. Allers über ein kleines Tastenfeld. Dann vielleicht auch wieder mit einer kleinen CPU. Atmel oder so. Kennst Du ja. Hat sowas mal jemand zu Ende gedacht oder zu Ende gemacht?

Gruss, Roland

Antworten:

Also, nach dem, was Klaus sagt und was ich mir aus Geros Worten zusammenreime, ist das Kabel Nr. 4 für mein Ansinnen ungeeignet und ich muss die Lösung auf der Laderplatine suchen. Ich muss eh an meine Platine, weil mein Lader erst bei zu hoher Spannung abschaltet. Mal abwarten, was Klaus erreicht.
Weiß jemand, wie die vier Leistungstransistoren heißen? Die werde ich ja wohl herausmontieren müssen? Oder? Geht schneller, wenn man weiß , welches Werkzeug...Hoffentlich keine 7-Eck Torx!

von Bernd Schlueter - am 02.04.2016 16:51
Zitat
Emobile Plus Solar
Ich wollte - wie in einem anderen Thread schon mal beschrieben - das Ladegerät von max. 16A Eingang auf max. 10A Eingang vom Netz umschalten.


Hm... Ich denke, die beste Lösung dafür wäre, mittels eines Microcontrollers / Embedded-Rechners / Smartphones o.ä. mit passendem K-Line interface die Parameter im Steuergerät umzuschreiben.

Das Problem daran ist, der Entwicklungsaufwand könnte gewaltig werden. Man müsste mittels Datenlogger auf der K-Leitung (Diagnoseleitung) mitlesen, wie das Lexia das macht, und das dann nachbilden.

Zitat
Bernd Schlueter
Ich muss eh an meine Platine, weil mein Lader erst bei zu hoher Spannung abschaltet.


Das macht nicht der Lader, die Regelung des Ladestroms und die Abschaltung erfolgt, wenn das stimmt was in meinem Lader-Thread gepostet wurde, im Rechner.


Zitat
Bernd Schlueter
Weiß jemand, wie die vier Leistungstransistoren heißen? Die werde ich ja wohl herausmontieren müssen?


Q1,Q2,Q3,Q4 jeweils IXTH24N50 - aber was versprichst du dir davon, die Endstufen aus dem Lader auszubauen? Ich glaube, das ist nicht zielführend...

Du brauchst 'nen Torx oder Schlitzschraubendreher für die 2 Schrauben am Deckel der Sagem, dann einen 13er Schlüssel für die Motor-und Batteriekabel, 'nen Torx oder Schlitz für die Schrauben von dem schwarzen Plastikteil in der Sagem und die Handvoll Schrauben am Deckel aussenrum, nen Torx für die Kupferschienen, nen Imbus für die 4 Bolzen die den Lader halten.

Wenn ich die Kiste wieder offen hab, kann ich dir die Größen der Torx mal aufschreiben - es sind auf jeden Fall mindestens 3 verschiedene Größen, es empfieht sich einen Satz Torx Schraubendreher zu haben, wenn man gern an der Kiste rumfummelt.

Der Imbus für den Lader ist ein 4er oder 5er, wenn ichs richtig im Kopf hab.

Ach ja, zum Zerlegen des Laders brauchst du auch wieder verschiedene Torx-Schraubenzieher... Doch, ja, es sind mindestens 4 verschiedene Torxgrößen in der Sagem, am besten du kaufst/leihst dir einen Satz...

von rostefix - am 03.04.2016 13:42
Doch, ist alles in meinem Koffer, müsste problemlos gehen.
Was ich mir immer noch nicht vorstellen kann, wie der Rechner an die 120 Volt kommen will. Alles, was 120 Volt betrifft, schwebt frei im Raum, bis auf den Isolationswiderstand, der mit der Luftfeuchte schwankt und manchmal die gelbe Lampe leuchten lässt, bis wieder rockenes Wetter ist.
Die einzige Übermittlung der 120Volt-Information kann meiner Meinung nur über einen Optokoppleroder Trafo erfolgen. Der zweite Optokoppler mit dem Tiefpass davor sagt aber, so verstehe ich das, nur, dass 230 Volt anliegen.
Es ist aber noch ein dritter Optokoppler zu sehen...
Wenn ich Herr Safran oder Kardamom wäre, würde ich das so machen, dass ich die Spannungsinformation vom Motorcontroller holen würde, die wird dort auf jeden Fall auch benötigt. Auch zum Schalten der diversen Warnlampen, so bei Unterschreiten von 102 Volt Da das ohnehin am Rechner ankommt, ist keine direkte Verbindung zwischen Lader und Rechner erforderlich. Es wäre sonst auch entsprechend am Lader und der Schnittstelle eingezeichnet. Dann kann die Leitung 4 auch alles übertragen und die PWM auf Cadmium und Blei und die verschiedenen Lademodes anpassen.

von Bernd Schlueter - am 03.04.2016 16:24
Zitat
Bernd Schlueter
Was ich mir immer noch nicht vorstellen kann, wie der Rechner an die 120 Volt kommen will.


Der bekommt die 120V von der Antriebsplatine über das Flachbandkabel. Und kann nicht isoliert (Trafo, Opto) sein, wie will er sonst die Isolation messen. Und Trafos funktionieren halt schlecht bei Gleichspannung. Ob da noch ein Teiler dazwischen ist, oder ob es wirklich die 120V direkt sind, weiss ich auch nicht.

von rostefix - am 03.04.2016 17:16
Klar, ist da ein Teiler drin, denn die PWM wird doch sicherlich mit einem Mikroprozessor erzeugt mit höchstens 5 Volt Eingang. Vielleicht aber auch mit diskreten Bauelementen, die Sagem-Box wurde schon vor langer Zeit entwickelt. Nein, galvanische Rückkopplung geht nicht, behaupte ich. Die Isolation wird vermutlich über einen 100kOhm-Widerstand (oder ähnlich) gegen einen Strommesseingang zwischen Boxgehäuse und Motor-controller-ground gemessen!?
Boxgehäuse und Rechner-ground dürften identisch sein! Also findet demnach die Isolationsmessung dann alleine auf den Rechnerplatinen statt.
Ich hoffe, in der nächsten Zeit Einblick zu bekommen (Boxen öffnen, vier kaputte warten auf Reparatur). Ich habe ja schwer Glück gehabt, dass ich rechtzeitig gesehen habe, dass meine Box den Motor ermorden und anschließend Selbstmord begehen wollte.

von Bernd Schlueter - am 03.04.2016 20:25

Re: Berlingo Ladestrom anpassen

hallo bernd

was verstehst du unter "galvanische Rückkopplung" ??
- trennung durch trafo, optokoppler etc oder
- direkt verbunden durch widerstand, leitung etc


Zitat
Boxgehäuse und Rechner-ground dürften identisch sein


diese aussage ist auch ein wenig unpräzise

wie du ja schon immer geschrieben hast besteht der calculateur aus _ 2 _ platinen und
auf jeder dieser platinen sitzt ein microcontroller

der eine hat sein "ground" potential auf Boxgehäuse (= minusanschluß der 12V-batterie)

der andere microcontroller hat seinen masseanschluß auf dem minusanschluß
der traktionsbatterie liegen (und dieser µP erzeugt auch das pwm fürs ladegerät)

servus...helmut

von `helmut` - am 03.04.2016 21:34

Re: Berlingo Ladestrom anpassen

Oh, das ist aber eine sehr wichtige Information! Ich hätte nie gedacht, dass eine Platine "frei schwebt". Es wird Zeit, dass ich mir das näher anschaue...Das heißt, die beiden Platinen kommunizieren auch über einen Optokoppler. Das macht alles komplizierter....dann wird die zweite Platine ja wohl auch vom Fahrakku versorgt? Über einen Trafo wäre auch möglich.
Was predige ich immer? Motor und Controller sollten eine Einheit bilden. Ich vermute, heute baut man anders. Nun, jetzt ist auch klar, warum zwei Platinen.Aber dann ist auch klar, wo die Softwareaufhänger her stammen,, Von der schwebenden Platine.
So werden natürlich auch Störimpulse der Motorkohlen in die Steuerung verschleppt. Wer weiß, vielleicht noch viel mehr, als wir registrieren. Nur fällt der Rechner dabei so schnell wieder auf die Füße, dass wir es gar nicht bemerken.

von Bernd Schlueter - am 05.04.2016 10:16

Re: Berlingo Ladestrom anpassen

du und deine vermutungen & theorien ...
da schwebt nix
alles schön an das jeweilige potential angebunden
und ja das mit dem näher anschauen wär wirklich eine gute idee
denn dann würdest du nicht immer drüber philosophieren
wie man es machen könnte
sondern wir könnten diskutieren
wie die sagem-leute es realisiert haben

leider fehlen im Plan_Calculateur_Partner-Berlingo_1
aus dem französischen forum ein paar seiten
dennoch ist das meißte nachvollziehbar
und im calculateur ist eh wenig basis für "optimierungen"
sollte aber wer wissen wo es einen kompletten plan gibt ...

die beiden platinen "kommunizieren" über mehrere optokoppler miteinander
versorgt werden beide über einen kleinen speerwandler
mit jeweils eigenen wicklungen aus dem fahrakku
und ich weiss nicht wie du auf die idee kommst da schwebe etwas

die platine welche für fahren & laden "zuständig" ist
liegt auf fahrakkupotential
genau wie der hacheur
verbunden mit diesem
durch das schon öfter erwähnte flachbandkabel
also gleiches potential vom microcontroller bis zu den igbt's
da ist wenig freiraum zum schweben

du schriebst weiter oben was von einer
"galvanischen rückkopplung"
was ist damit gemeint ??
der ausdruck ist mir nicht geläufig

servus...helmut

von `helmut` - am 05.04.2016 19:37

Re: Berlingo Ladestrom anpassen

Galvanisch: eine ohmsche Verbindung, also nicht über Optokoppler oder Trafo.
Schwebend: keine galvanische Verbindung zwischen Gehäuse und Prozessorplatine, deshalb die von Dir genannten Optokoppler
Ich muss leider noch philosophieren und ehe ich meine box öffne, versuche ich hier, zu erfahren, was möglich ist.
Jetzt habe ich endlich die Schaltpläne , zwar nur für die Fabrikation, also mit Fehlern und unübersichtlich, aber das Nächste wird sein, alles auf einzelne Blätter zu kopieren und dann zusammenzukleben, um eine Übersichtlichkeit zu erhalten. Dann erst geht es an die geöffneten Boxen. Im Moment ein wenig Ferien...
Ja, die vielen Trenntrafos habe ich gesehen.
Rückkopplung: da die eine Rechnerplatine auf dem "schwebenden" Potential liegt, geschehen Messung und Auswertung alle auf der Platine und diese gibt auch die PWM für die 230 Volt-Seite aus. Eine Prüfschaltung auf der gleichen Platine untersucht auf Plausibilität. Wenn eine Störung, Abbruch des Ladens. Das wird mir wohl die meisten Schwierigkeiten bereiten. Gero hat das wahrscheinlich noch nicht entdeckt, weil es erst verspätet eintritt? Mir gefällt überhaupt nicht, dass die Rechnerplatine für den Lader nicht auf Gehäusepotential liegt, denn dann "schwebt" auch unser Zusatzregler. Allerdings können wir diesen, auf der gleichen Platine, mit mehreren Optokopplern ausrüsten, als Eingang oder Ausgang. Unabhängig davon muss ich auf andere Weise noch meine Laderspannung korrigieren, die bei meinem Saxo ca 8 Volt zu hoch liegt und die Akkus tötet.
Das war wohl im Endeffekt der Grund dafür , dass mein Auto auf dem Schrottplatz stand. Citroen Düsseldorf hatte aufgegeben, das RWE stieß daraufhin alle Saxos ab.
Auch mit Citroen in Köln Porz hatte ich ähnliche schlimme Erfahrungen gemacht, mit einer Ente und einem Ami-Super = Superente. "Ölfraß" nannte ich beide. Dass die Kurbelwelle schief zusammengesetzt war, bekamen die nicht auf die Reihe. Garantie: die war nichts wert, nur Ärger.
Ich habe danach immer Citroen, aber nie mehr Neuwagen gekauft. Uns lassen die hier ja auch alleine im Regen stehen. Wenn Philippe nicht wäre...

von Bernd Schlueter - am 06.04.2016 13:23
Zitat
Bernd Schlueter
Auch mit Citroen in Köln Porz hatte ich ähnliche schlimme Erfahrungen gemacht,


Das sind auch nur Mechaniker. Harte Arbeit, schlecht bezahlt. In der Berufsschule noch gelernt wie's geht, Anlasser und Lichtmaschinen revidieren, In die Steuergeräte reinschauen (auch Hardware), reparieren, was können - und in der Firma dann 90% Öl, Bremsen, Reifen, 10% Fehlersuche, davon 10% reparieren durch Teiletauschen, oder verschrotten - das macht dich fertig.

Zitat
Bernd Schlueter
Unabhängig davon muss ich auf andere Weise noch meine Laderspannung korrigieren, die bei meinem Saxo ca 8 Volt zu hoch liegt und die Akkus tötet.


interessant. Ist das die originale Akkubestückung? 8V zu viel - hast du's gemessen, also 251V beim Berlingo, oder wie hast du es bemerkt? Oder musst du deinen Lader justieren weil LiFePo?

von rostefix - am 06.04.2016 20:29
Hallo,
Citroen Porz kann man vergessen, da sitzt nur die Verwaltung, und die scheint nur die Aufgabe zu haben Neufahrzeuge zu verkaufen.
Mit meinem AX-E kann ich zu Citroen Köln fahren, wenn etwas (nicht elektrisches, dafür ist Gero zuständig) zu machen ist. Da werde ich nicht gleich wieder herausgeworfen, die haben Erfahrung mit Electiques - sie hatten die Berlingos von Rheinenergie in der Wartung - und mein AX ist nicht der einzige in Köln.
Grüße

Lothar

von el3331 - am 06.04.2016 20:47

Re: Berlingo Ladestrom anpassen

hallo bernd

du bist ja der volle verschwörungstheoretiker
warum sollten produktionpläne fehlerbehaftet sein ??
und mehrseitige schaltpläne sind irgendwie immer unübersichtlich
das bringen ein paar hundert bauteile so mit sich

meinst du mit "prüfschaltung" die schaltungsmimik auf seite 28 (32/37) vom plan_calculateur_1 ??
da wird nur entschieden wer mit der pwm bedacht wird
- ladegerät oder feldspulenansteuerung -
(störungen werden da nicht berücksichtigt)
die beiden eingangsgrößen der schaltung
- pwm1 und mux_pwm1 -
kommen vom microcontroller

das was auf der carte_cpu_ht passiert ist zwar alles hochspannend
aber damit musst du dich eigentlich nicht rumschlagen

deine anforderungen bekommst du doch alle
über eine manipulation der pwm_chargeur geregelt
ladegerät soll leistung hochfahren --> impulspausenverhältnis größer machen
ladegerät soll leistung runterfahren --> impulspausenverhältnis kleiner machen
akku soll nicht so voll geladen werden --> impulspausenverhältnis schon bei niedriegerer spannungsschwelle runterdrehen

das einschleifen des pwm-manipulateurs in das flachbandkabel
wie klausA es in seinem beitrag beschrieben hat
ist eine sehr feine möglichkeit
ohne große kollateralschäden was zu erreichen

und eigentlich macht er mit seiner platine genau das was du brauchst ....
frag ihn doch mal
vielleicht hat er ja noch eine übrig

servus...helmut

von `helmut` - am 06.04.2016 22:20
Widdersdorfer Straße? Meine schlechten Erfahrungen hatte ich noch auf der Aachener Straße und in Poll gemacht. Eigentlich in Poll, weil die es nicht schafften , eine verdrehte Kurbelwelle zu diagnostizieren, was zu immensem Ölverbrauch führt. Damals wurde St. Quen in Paris geschlossen wegen der Fabrikationsprobleme. Die Kurbelwelle ist bei der Ente aus mehreren Teilen zusammengeschrumpft. Ich bin später immer ins Schwäbische gefahren.
Bei Gebrauchtfahrzeugen kann man sich aussuchen, was man bekommt.
Also, Widdersdorfer Straße. Düsseldorf und Umfeld, die gehen alle laufen, wenn sie ein Elektroauto sehen.
Mein Saxo schaltet beim Laden überhaupt nicht ab und lädt die Batterien kaputt. Wenn es sehr warm ist im Sommer, dann erreichen sie manchmal die notwendige Abschaltspannung, ober, wenn ich einen weiteren Batterieblock hinzusetze. Das müsste man aber an einem Spannungsteiler korrigieren können. Ich hatte das Problem bisher mit einer Zeitschaltuhr gelöst.
Der Fehler muss wohl von Anfang an bestanden haben, denn die Akkus wurden im ersten Jahr ausgetauscht, Nach 8 Jahren landete der Wagen auf dem Schrott mit 2km Reichweite nach meiner Reparatur. Ich peppelte die Batterien mit meiner Zeitschaltuhrmethode bis auf gut 90 km Reichweite auf. Jetzt geht es dem Fehler an den Kragen.
Also, ist die PWM-Steuerung doch völlig unproblematisch.Von anderer Seite wurde mir gesagt, dass da doch eine Art Überprüfung hineinspielt, also doch nicht. Die Schaltung von Klaus entspricht in der Funktionsweise genau der von uns vorgesehen, wenn auch anders gelöst, mit zwei Optokopplern. Die Mühlengeneratorfrequenz bekommen wir ja ebenfalls in der Box, über einen Netztrafo. Wir müssen nur alles unterbringen...möglichst innerhalb der Box. 12 Volt / 25mA werden benötigt, oder stabile 5 Volt.
Auf dem Plan steht "nur für die Fabrikation bestimmt", jemand hier im Forum entdeckte einen Optokoppler, der in der falschen Richtung gezeichnet ist. Deshalb dachte ich, dass Vorsicht geboten ist. Außerdem ist mein Saxo kein Berlingo.

Es müsste alles so funktionieren, wie wir schon vor Monaten aufgrund der Auskünfte von Gero geplant haben. Da eine PWM-Gleichspannungswandlung mit Tiefpass vorhanden ist, können wir entweder das Taktverhältnis der PWM im in Leitung 4 eingeschleiften Prozessor ändern, was mehr Programmieraufwand erfordert, oder wir modulieren einfach eine zweite, in der Frequenz sehr verschiedene PWM "über". Sprich, wir bilden das Produkt bzw. wir mischen mit einem "oder" die zwei Signale. Das spart Speicherplatz, denn die Platine muss auch die Mühle regeln.

Dabei müssen wir Schwebungen vermeiden. Geregelt wird von der aufmodulierten PWM zwischen 0 und 100%, während die bordeigene den Ladevorgang überwacht. Ich bin mal gespannt,ob nicht doch etwas dazwischenfunkt, wenn wir vorübergehend den Saft ganz abdrehen. Irgendjemand meinte, ein Abschalten beobachtet zu haben.
Alles andere würde dann normal funktionieren.

von Bernd Schlueter - am 07.04.2016 09:05
hallo bernd

Zitat
Das müsste man aber an einem Spannungsteiler korrigieren können


r85+r86+r87/r88 auf seite 25 (29/37 - calculateur) ändern ??
das meinst du jetzt aber nicht ernst

Zitat
jemand hier im Forum entdeckte einen Optokoppler, der in der falschen Richtung gezeichnet ist. Deshalb dachte ich, dass Vorsicht geboten ist.


das haben rostifix & klaus mal thematisiert
flachbandkabelstecker P1
da stimmen die richtungssymbole der ein/ausgehenden signale im plan nicht alle
seite 44 (3/3 - hacheur (puissance chargeur))
die optokoppler sind alle richtig gezeichnet

Zitat
Außerdem ist mein Saxo kein Berlingo


in der sagembox sind die unterschiede marginal
bestenfalls bestückungsvarianten im ladegerät & dc-wandler
(bei den trafos und spannungsteilern)
aber calculateur & hacheur sind gleich

Zitat
Irgendjemand meinte, ein Abschalten beobachtet zu haben.


ca 28 min nach ladebeginn geht der ladestrom auf 0 A
(timer im ladegerät abgelaufen)
der calculateur stellt die pwm-vorgabe ab
und beginnt von neuem
das ist normal und so gewollt
28 min später: siehe oben

servus...helmut

von `helmut` - am 10.04.2016 22:24
Von Wotan habe ich jetzt auch noch die nötigen Informationen über die Waldmühlen-Zusatzlader bekommen, dann kann ja bald nichts mehr passieren. Ihr kennt Euch ja richtig aus!
R85...87. Das sieht ja ganz nach der richtigen Stelle aus! ca 140kOhm zu einem der Wderstände parallel, das könnte meinen Lader wieder in Ornung bringen? Das hätte ich ja nie gefunden!
Jürgen in Köln steht jetzt an, mit defekter Sagem und zweiter geöffneter Box, Paul in den Niederlanden, und dann geht es zur Waldmühle (noch vor dem Mühlentreffen).

Helmut, habe den Calculateur vor mir. R85 bis R88 finde ich nicht auf den beiden Calculateurrückseiten. Wo mögen die sich verstecken? Doch auf der hacheurplatine?

Scheint mir ziemlich plausibel, dass da der Fehler meines saxo versteckt sitzt. Nur, wo finde ich diese?

Ha, Verdacht! Unter der Platine Sagem PIU...3 kleine blaue konventionelle Widerstände auf der Oberseite der Platine, also die die nach innen zeigt? C237 und C238 sind auch in der Nähe, auf der anderen Seite, aber nicht C239. Ich brauchte eine Lupe oder noch besser, den Helmut fragen.

Wenn es so wäre, brauchte ich nur meinen korrekturwiderstand auf die zugängliche Seite löten und Deutschland steht mir offen.

von Bernd Schlueter - am 11.04.2016 00:19

Berlingo Ladestrom/Ladespannung werden jetzt angepasst

Die Sonne scheint, die Vögel singen und die drei Widerstände von je 56,2kOhm leuchten mir farbig, auch ohne Lupe erkennbar in meiner Version 3.5 entgegen. Sie sind es und damit dürfte ich wohl einen rein analogen Zugang zur Einstellung der Laderspannung und damit auch zur Ladestromstärke haben. Kein Eingriff in die PWM nötig, die doch elektrisch risikoreicher wäre als das direkte Herauslegen eines Kabels über zwei 1MOhm-Widerstände aus der Box heraus.
Zwei freie Pins auf der 55 poligen Steckleiste finden sich vermutlich auch noch. Vielleicht schließe ich zusätzlich noch meine Zeitschaltuhr im Handschuhfach an, oder wer sonst eine geignete Stelle für eine geeignete Uhr weiß. Die ist dann natürlich mit Lithiumbatterie ausgerüstet. Irgendwann muss der Umbau auf Lithium schließlich mal beginnen.

Für die Waldmühlensteuerung das Gleiche: nur über den Universalregler, mit Frequenzmessung und Optokoppelei ausgerüstet. Also nicht mehr über die Unterbrechung von Kabel Nr.4.

Dann werde ich mich jetzt mal um den nächsten Punkt kümmern:
Warnlampe für den gefährlichen Betriebsmodudus mit dem 2,5 fachen Stromverbrauch. Da die experten ja anwesend sind, meine Frage: An welchen Stelle komme ich bequem an die Motor-Stromaufnahmeinformation? Dann vielleicht auch gleich an die des Stromverbrauchs der Batterie? Der notgedrungen niederohmige direkte Anschluss an den shunts würde mir nicht gefallen. Halleffekt-Strommessung?
Dann würde ich die Regelung für einen Gleichstrom-Batterieanschluss ins Fahrzeug verlegen. Den Optokoppler- Zugang im HP-Netzteil habe ich ja bereits gefunden.
Das übernimmt dann alles ein einziger Universalregler mit Tiny, der genügend Ein-und Ausgänge besitzt. Auf der Platine ist auch Platz für den nächstgrößeren Atmel, Da müssen nur ein paar Anschlüsse umgelegt werden. Wahrscheinlich kommen wir aber hin. Notfalls statt Delphikompiler direkte Maschinensprache. Außer Integer-Arithmetik wird praktisch nur duale Logik benötigt.

von Bernd Schlueter - am 12.04.2016 08:11

Re: Berlingo Ladestrom/Ladespannung werden jetzt angepasst

Zitat
Bernd Schlueter
meine Frage: An welchen Stelle komme ich bequem an die Motor-Stromaufnahmeinformation? Dann vielleicht auch gleich an die des Stromverbrauchs der Batterie?


Hallo Bernd,
.. und ich dachte immer, Du ziehst es vor, solche Messtechnik lieber außerhalb zu installieren.
Ich würde nur den Deckel der Box aufschrauben und jeweils einen Shunt in die Batterieleitung und in die jeweiligen Motorleitungen einschleifen. Da hast Du mit überschaubarem Aufwand schöne Werte für handelsübliche Messgeräte oder Deine Steuergeräte.


Batteriestrom in den Minusanschluss einschleifen, also Verbindung Nr. 9313.
Motorstrom in die Verbindung 9210, und Erregerstrom in die Verbindung 92201.


Also Shunt an den Anschluss, wo jetzt das grüne Kabel zu den 120 V Batterien geht. Rechts daneben sind die Motorkabel. Wenn man die dicken Kabel löst, kommt man an die darunterliegenden Anschlüsse für die Motorerregung. Ist doch alles sehr gut zugänglich, ohne dass man die Box wirklich öffen muss.
Statt der dicken Kabelschuhe kann man auch direkt einen handelsüblichen Shunt draufschrauben, das Kabel kommt dann an den oberen Shunt Anschluss. Handelsübliche Shunts sind 20 mm breit, der Kabelschuh hat 18 mm Breite. Also muss man die Shunts mechanisch etwas anpassen durch kleiner Feilen oder Fräsen. Alles machbar mit vertretbarem Aufwand.
Hatte eine Berlingo Box gerade mal geöffnet und ein wenig rumprobiert mit den Shunts, die ich hier noch so rumliegen habe. Mechanisch würds schon gehen, ich muss nur noch den richtigen Shunt besorgen. Ich hatte an einen 150A 60mV Shunt gedacht, hier z.B. von Conrad. 150A Shunt sollte schon reichen, die 200A fliessen ja nicht so oft und dann immer nur kurzzeitig.

Gruss, Roland

von Hotzi-47 - am 12.04.2016 14:55

Re: Berlingo Ladestrom/Ladespannung werden jetzt angepasst

Die shunts sind doch schon in der Box, und falls die an den Minusleitungen befestigt sind, kann ich doch die Shuntspannungen zwischen Mareshallstecker-Minus , und Motor - Minus oder Batterieminus abgreifen. Das müsste aber durch abgesicherte Leitungen mit hohem und sicheren Isolationswiderstand geschehen und auch die Instrumente würden auf dem Isolationsniveau liegen, was mir nicht sonderlich behagt. Ach, ich denke, das kann ich aber wagen. Lange 10kOhm-Schutzwiderständeals Sicherung vor mV-Metern zur Strommessung. Dazu ein Verstärker, der eine Lampe aufleuchten lässt, wenn 100 Ampere unterhalb einer bestimmten Gaspedalstellung überschritten werden (2,5 fach-Strommodus bzw. zu geringer Strom des "Induit"-Kreises).

Meine Ladespannungskorrektur habe ich jetzt hoffentlich durchgeführt, es regnet jetzt und ich warte ab mit dem Einbau.

von Bernd Schlueter - am 12.04.2016 17:50

Re: Berlingo Ladestrom/Ladespannung werden jetzt angepasst

Zitat
Bernd Schlueter
Meine Ladespannungskorrektur habe ich jetzt hoffentlich durchgeführt.


Würde ich auch gerne machen. Schick mal ein Foto und den Plan damit ichs nachmachen kann. Wenns geht.

Gruss, Roland

von Hotzi-47 - am 12.04.2016 21:08

Re: Berlingo Ladestrom/Ladespannung werden jetzt angepasst

Zitat
EMobile plus solar
Zitat
Bernd Schlueter
meine Frage: An welchen Stelle komme ich bequem an die Motor-Stromaufnahmeinformation? Dann vielleicht auch gleich an die des Stromverbrauchs der Batterie?


Ich hatte an einen 150A 60mV Shunt gedacht, hier z.B. von Conrad. 150A Shunt sollte schon reichen, die 200A fliessen ja nicht so oft und dann immer nur kurzzeitig.

Gruss, Roland

Hätte ich.
woti

von wotan,der ältere - am 13.04.2016 14:18

Re: Berlingo Ladestrom/Ladespannung werden jetzt angepasst

Ich fürchte, dass die Shunts des Saxos zwischen den drei Minus-Hochstromanschlüssen lliegen, dann würde es reichen , an drei Anschlüssen (13er Muttern) die Spannungen abzugreifen und hochohmig über Schutzwiderstände ins Innere an zwei Milliamperemeter zu leiten.

Dank Helmut schaltet meine Kiste jetzt endlich ab, bevor die Batterien überladen werden. Hätte ich den Helmut bloß früher gefragt, hätte mir für fast 1000 Euro Batterien undunendlich viel Ärger erspart. Es kommt schon auf 2 Volt Spannungsdifferenz an, ob der lader nie oder rechtzeitig abschaltet. Jetzt habe ich eingestellt, dass die erste Abschaltung bei 152 Volt beginnt . danach wird die ladung sehr schnell beendet. Bei schätzungsweise 18 Grad Celsius Temperatur.
Hat das schonmal jemand kontrolliert? Ich kann jetzt beliebige Abschaltspannungen per 500 kOhm-Poti parallel zum mittleren 56,2 kOhm-Widerstand einstellen (R87 oder wie der heißt.

Nein, meinen Ladestrom kann ich da nicht reduzieren, das muss im Chargeur passieren. Ich vermute, da gibt es verschiedene Eingreifmöglichkeiten ohne Auftrenn-und Zwischensteckerei, direkt. 5 Volt sind vorhanden,lese ich im Plan, da kommt auch unser Regler dran, der dann nur noch 3X5cm klein ist. Heißt ja auch "Tiny". 50Hz: Brummtrafo oder 2 gegeneinandergeschaltete Optokoppler an die 220 Volt. Nur da und an der Stromeinstellung von Hand benötige ich eine Potentialtrennung.

Da fällt mir ein, jeder, der auf andere Batterien oder auf andere Spannungen umrüstet, muss ja wohl an diesen Spannungsteiler , der aus den Widerständen R85,86,87 und R88 besteht, heran.
Parallel zu R88 schaltet man einen Korrekturwiderstand, um die Ladespannung zu erhöhen, parallel zu einem der anderen, um diese zu senken.
Also, diese Widerstände sitzen auf der Innenseite der Platine ohne Pfostenstecker, man muss diese Platine also lösen und hochklappen. Es sind die einzigen Präzisionswiderstände, bei mir sind die drei gleichen grün-blau-rot-rot, also 56,2 kOhm, herkömmliche Bauform, also keine SMD.
Anderes Ende: grüner Farbring = Toleranz +/-0,5%. R88 weiß ich nicht, 3,2 kOhm, ebenfalls 0,5%.

von Bernd Schlueter - am 14.04.2016 12:00

Fehler, Aussetzer für 1/3 Sekunde

Nachdem ich die wahrscheinlich von Anfang an fehlerhafte Spannungsmessung im Hause Sagem korrigiert habe, habe ich einen schwerwiegenden Denkfehler zum Besten gegeben: die blöde Kiste schaltete nicht einmal nach Erreichen von 162 Volt ab, sondern ludt und blinkte fröhlich weiter .
Große Pleite, dachte ich, bis ich, mit einem Viertel Tag Verspätung auf die glorreiche Idee kam, mich mal an die überfällige Ausgleichsladung zu erinnern. Ich denke mal, das wird von Zeit zu Zeit immer mal passieren, oder habe ich Unrecht in der Annahme, dass meine Annahme falsch ist?

Zum Jürgen bin ich heute gar nicht erst gekommen. Ihr könnt Euch nicht vorstellen, welch ein Verkehrsgewühle heute vor und in Düsseldorf war. Mit viel zu leerem Tank und nach unmöglichen Umwegen kam ich an der Ladestation an, zu spät für das Treffen mit Jürgen zur Sagembox-Reparatur.

Vertrauend auf google maps, dem ich ab gestern nicht mehr vertraue. Lasst Euch nicht auf nicht existierende Straßen schicken und wisst, dass weite Fahrten mit dem Elektroauto zu vermeiden sind. Bricht die Elektromobilität erst einmal richtig Bahn, wird der Verkehr nicht nur deutlich leiser, sondern auch weniger, denn die dauernde Laderei nervt.

Meine Kiste ruckt unbeeindruckt von Beseitigung von Wackelkontakten, munter weiter. gestern gleich zwei mal, diesmal beim Anfahren. Beim "verschlucken" fällt dann "klack", das Hauptrelais ab und schaltet nach einer Drittel Sekunde wieder ein.

Beobachtung: Nach dem letzten "Klack" bin ich wieder im Modus mit nur halber Rekustärke.
Auf dem steilen Berg im Duisburger Wald beschleunigt die Kiste dann wieder bei 9% Gefälle, statt langsamer zu werden.

Nach weiteren 70km Strecke wieder zweimal der Aussetzer beim Beschleunigen. Sollte ich nach den Kohlen schauen? Jedenfalls, jetzt ist die Reku wieder normal, sprich, volle Kraft.

von Bernd Schlueter - am 16.04.2016 00:25

Re: Fehler, Aussetzer für 1/3 Sekunde

Hallo


Die version 3.5 macht jedes 10te mal eine Ausgleichsladung steht jedenfalls so im Handbuch.


Gruß

Roman

von R.M - am 16.04.2016 17:54
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.