Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
PYTHA
Beiträge im Thema:
19
Erster Beitrag:
vor 4 Jahren, 3 Monaten
Letzter Beitrag:
vor 4 Jahren, 3 Monaten
Beteiligte Autoren:
Markus Seidel, Cornelius Adam, J.F., Tommy Rothämel

RadioLab hängt sich beim Einschalten der Lichtquellen auf

Startbeitrag von J.F. am 04.10.2013 08:31

Guten Morgen,leider hängt sich mein Pytha jedesmal beim Einschalten der Lichtquellen auf.Ich bekomme folgende Nachricht "Schattengrenzen auf %d/%d.Fläche werden berechnet"und danach passiert nichts mehr.
Für den goldenen Tip wäre ich sehr dankbar.
ein schönes Wochenende
Jan Fricke

Antworten:

Hallo Herr Fricke,

die Meldung besagt ziemlich alllgemein, dass Sie nicht genug Speicher zur Verfügung haben. Das kann am Arbeitsspeicher liegen oder die Ursache ist vielleicht, dass das Projekt schon zu groß ist. Möglicherweise habern Sie zuviele Leuchten eingefügt?

Können Sie ein paar Rahmendaten liefern? Wie groß ist die .rlb-Szene, bevor Sie die Lichtquellen einschalten? Wie ist Ihr Rechner konfiguriert? Prozessor, Anzahl der Kerne, RAM, SSD,Grafikkarte?

Mit freundlichen Grüßen von

Cornelius Adam

von Cornelius Adam - am 04.10.2013 08:37
Hallo Herr Adam,
die Szene ist 630MB groß und hat recht viele Lichtquellen ca.80 (auch wenn ich diese einzeln anschalte kommt die Nachricht).

Intel-Prozessor i5-2500CPU,3.30GHz
RAM 4,00GB
Festplatte111GB
NVIDIA GeForce GTX 680

MfG
Jan Fricke

von J.F. - am 04.10.2013 09:07
Hallo Herr Fricke,

welches Betriebssystem (32/64 Bit) verwenden Sie?
Sind die Lichtquellen Flächenlichtquellen oder Spots?

Mit freundlichen Grüßen von

Cornelius Adam

von Cornelius Adam - am 04.10.2013 09:16
Macht es denn einen Unterschied ob 32 oder 64 Bit? Ich dachte immer Pyhta ist eine 32 Bit-Anwendung.

von Markus Seidel - am 04.10.2013 09:51
Hallo Herr Seidel,

ganz recht, Pytha ist (noch) eine 32-Bit-Anwendung. Meiner Erfahrung nach, auch wenn diese subjektiv ist, laufen große Projekte unter WIN 64 mit (bei mir) mit SSD und 16 GB RAM sehr gut. Auf meinem alten Laptop mit XP und 4 GB war bei ca. 900 MB Schluss, auf meinem jetzigen Desktop sind Szenen mit 1,2 GB noch machbar.

Mit freundlichen Grüßen von

Cornelius Adam

von Cornelius Adam - am 04.10.2013 09:58
Hallo
das Betriebssystem ist 32Bit und ich habe nur Spots verwendet.
Gruß
Jan Fricke

von J.F. - am 04.10.2013 09:58
Hallo Herr Fricke,

versuchen Sie mal, den Berechnungsaufwand zu reduzieren: Weniger wichtige Objekte auf einen inaktiven, aber sichtbaren Layer legen und die Anzahl der Lichtquellen auf die Hälfte reduzieren.

mit welcher Version von Pytha arbeiten Sie (V19, 20, 21?) Hatten Sie kürzlich ein Windows-Update?

Mit freundlichen Grüßen von

Cornelius Adam

von Cornelius Adam - am 04.10.2013 10:25
Sind vielleicht viele Flächen mit Shadern belegt? Oder viele transparente oder spiegelnde Flächen?

von Markus Seidel - am 04.10.2013 10:54
Ich habe die ganze Szene einfarbig,alle Texturen gelöscht und die Shader ausgeschaltet.Beim Licht einschalten erhalte ich leider immer noch das gleiche.

von J.F. - am 04.10.2013 11:10
Ich finde es dann auch immer sehr frustrierend wenn man außer so´n komisches "Schattengrenzen"-Gedöns keinerlei Rückmeldung vom Programm erhält und man dann rumprobieren muss um evtl. eine Lösung zu finden. Das finde ich sehr schlecht an dem Programm. Ein großes Minus!

von Markus Seidel - am 04.10.2013 11:34
Wenn Sie mögen, schicken Sie mir die .pyo-Datei gezippt zu, ich versuche es mal. Die E-Mailadresse fiden Sie in meinem Profil.

Mit freundlichen Grüßen von

Cornelius Adam

von Cornelius Adam - am 04.10.2013 11:41
Wenn ich einzelne Teile aus der Szene herausnehme funktioniert es einwandfrei.Leider halt nicht im Big Picture.Vielleicht liegt es ja doch am Rechner (da muß die EDV am Montag ran :angry:.)

von J.F. - am 04.10.2013 11:48
Haben Sie sich die einzelnen Teile mal näher angesehen?
Sind diese beschädigt?

von Cornelius Adam - am 04.10.2013 11:55
Gibt´s denn im RadioLab eine passende Funktion (wie im Einga) um Bauteile auf ihre Gültigkeit zu testen, oder geht das nur so per Auge?

von Markus Seidel - am 04.10.2013 12:22
Ja genau,Fehlerquelle ist gefunden.Da muss ich wohl den Übeltäter nochmal überarbeiten.
Vielen Dank für die Unterstützung
und ein schönes Wochenende
Jan Fricke

von J.F. - am 04.10.2013 12:22
4 Stunden Fehlersuche^^

Schön das Sie den Fehler gefunden haben! :-)

von Markus Seidel - am 04.10.2013 12:24
Hallo alle Zusammen,

diese Fehlermeldung besagt, dass nicht genügend Speicher zur Verfügung steht.

Das einfachste Lösung ist, dass man die Anzahl der Lichtquellen reduziert. Das kann man in V21 einfach dadurch machen, dass man Lichtquellen im Lichtcontainer zusammenfasst. (LQ lassen sich dann nur noch zusammen ein/ausschalten).

von Tommy Rothämel - am 04.10.2013 12:24
Auf welcher Seite im Handbuch findet man denn Informationen über diese Lichtcontainer Herr Rothämel?

von Markus Seidel - am 04.10.2013 14:31
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.