Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
PYTHA
Beiträge im Thema:
17
Erster Beitrag:
vor 4 Jahren, 2 Monaten
Letzter Beitrag:
vor 4 Jahren, 2 Monaten
Beteiligte Autoren:
Holger Kern, Florian Spicka, Olaf Jehn, Cornelius Adam, Uschi Flassig, Mikkel Krabbe, Carl C. Fink, Markus Seidel

Material

Startbeitrag von Holger Kern am 06.11.2013 09:56

Hallo zusammen,

hab folgendes Problem:

wenn ich ein neues Material in einer Materialdatei anlege, erscheint kein Vorschaubild. Auch wenn ich ein bestehendes ändere, erscheint kein Vorschaubild mehr.
Weiß jemand, woran das liegen kann?

Danke und beste Grüße
Holger Kern

Antworten:

Hallo Herr Kern,

ist "Vorschau" angehakt? Haben Sie auf die Taste "Zeigen" geklickt? Wie groß in kB/MB ist die Textur, die Sie verwenden möchten? Liegt diese lokal auf Ihrem Rechner vor oder wird sie durch das Netzwerk geladen?

Mit freundlichen Grüßen von

Cornelius Adam

von Cornelius Adam - am 06.11.2013 10:21
Hallo Herr Adam,

Größe der Textur ist 323 KB, liegt auf meinem Rechner.
Vorschau ist angehakt, Zeigen hab ich geklickt.
Kommt nur schwarzer Hintergrund.

Gruß
Holger Kern

von Holger Kern - am 06.11.2013 10:28
Hallo Herr Kern,

hat es bis vor Kurzem funktioniert?
Wenn ja: was hat sich in den letzten Tagen an Ihrem Rechner verändert? Windows-Update? PYTHA-Update?

Freundliche Grüße

U. Flassig

von Uschi Flassig - am 06.11.2013 10:30
Hallo Frau Flassig,

hatte bisher am Material noch nichts verändert. Hab immer bereits bestehende genommen.
Updates gabs keine. Gibts denn von Pytha ein neues Update?

Gruß
Holger Kern

von Holger Kern - am 06.11.2013 10:34
Hallo Herr Kern,

ich glaube, wenn das JPG als Progressives JPG vorliegt, dann wird es nicht angezeigt.
Zumindest hatte ich solch einen Fall mal.

Nun könnte es sein, dass Sie das JPG in einem anderen Programm editiert haben und dort beim Abspeichern entsprechend Optionen gesetzt waren.

Alternativ kamen Ihre Symtome auch mal bei einem Update vor, damals musste eine dll Datei ersetzt werden.

Führen Sie Pytha als Administrator aus. Bei mir funktioniert der Raytracer sonst gar nicht. Vielleicht behebt das dann eine Ordnerberechtigung, etc.

Gruß
Olaf Jehn

von Olaf Jehn - am 06.11.2013 15:30
Hallo Herr Jehn,

es verhält sich momentan so:
wenn ich z.B. in der bestehenden Materialdatei pytha_holz (Vorschaubilder sichtbar) bei einem Material z.B. einen Schieberegler (Spiegel, etc...) nur leicht verändere und sichern anklicke, dann ist das Vorschaubild plötzlich nicht mehr sichtbar. Warum auch immer?


Gruß
Holger Kern

von Holger Kern - am 06.11.2013 16:29
Hallo Herr Kern,

so langsam kommen wir dahinter...
Die Materialdatei pytha-holz.mat hat von Anfang an nicht richtig funktioniert.
Prüfen Sie mal, ob die Texturenpfad richtig ist.
Versuchen Sie mal ein Material selbst neu zu erstellen.

Mit freundlichen Grüßen von

Cornelius Adam

von Cornelius Adam - am 06.11.2013 17:25
Das Problem hatte ich auch mal, bei mir lag es daran das der Dateiname der Bilddatei zu lang war, käme das vielleicht auch bei Ihnen in Frage?

von Markus Seidel - am 06.11.2013 18:07
Hallo Herr Kern,

auch wenn es momentan nicht weiter hilft, aber meine Materialdatei pytha_holz (unverändert seit 2005!) lässt sich einwandfrei editieren und ergänzen. Ist es denn bei allen Materialdateien so? Laden Sie mal eine neue von einer CD herunter oder erstellen Sie eine neue Datei.
Ich hatte das Problem auch mal. Es lag am Rechner (BS, Datei, Grafikkarte,...), aber leider kann ich mich nicht mehr an die Lösung erinnern. Herr Spicka wusste eine Lösung.

von Carl C. Fink - am 06.11.2013 18:17
Hallo,

danke erstmal für die vielen Tipps.

Aber ich hab jetzt mal die original Pytha.mat probiert und hier ist es das gleiche. Wenn ich neues Material anlege, gibts kein Vorschaubild.
Naja, wichtiger ist ja, dass das Material trotzdem vorhanden ist und auch auf das Bauteil aufgetragen wird, das funktioniert.

beste Grüße
Holger

von Holger Kern - am 06.11.2013 18:29
Hallo Herr Kern,
Können Sie im Einga ein normales Raytracing-Bild laufen lassen?
Gruß
U. Flassig

von Uschi Flassig - am 06.11.2013 22:54
Hallo Frau Flassig,

ja, das funktioniert.

Gruß
Holger Kern

von Holger Kern - am 07.11.2013 06:13
Hallo Herr Kern,

falls der Materialeditor kein Vorschaubild des Materials anzeigt wird
eine DLL Datei nicht gefunden. Um dem Betriebssystem auf die Sprünge
zu helfen ist eine Umgebungsvariable mit dem Namen „PYTHA“ notwendig
die auf den Installationsordner von PYTHA verweist.
Gerne können Sie sich direkt an das PYTHA Mutterhaus in Aschaffenburg wenden
damit wir diese Variable gemeinsam erzeugen können. (06021/37060)

mit freundlichen Grüßen
Florian Spicka

von Florian Spicka - am 07.11.2013 06:58
Hallo Herr Jehn,

wenn wie in Ihrem Fall der PYTHA Raytracer nur mit Administratoren Berechtigungen läuft kann
PYTHA beim Rechnen eines Bildes die notwendigen Triangulations Dateien TRI und TRG nicht
in den Temp Ordner von Windows schreiben. Es hängt mit den fehlenden Benutzerberechtigungen zusammen.
Es lässt sich umgehen wenn man die Systemvariablen TEMP und TMP manuell auf einen neuen
Ordner, z.B. c:\Temp umstellt.
Gerne sind wir dabei behilflich.

mit freundlichen Grüßen

Florian Spicka

von Florian Spicka - am 07.11.2013 07:02
In der Tat, Problem behoben ... ! Benutzervariablem auf ein Verzeichnis umgeleitet.

Wir hatten darüber gesprochen, leider hatte ich es wieder vergessen.

Danke schön.

von Olaf Jehn - am 07.11.2013 19:13
Hello

Perhaps the picture is in CMYK mode instead of RGB ??

Regards
Mikkel Krabbe

von Mikkel Krabbe - am 08.11.2013 07:14
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.